PT-2017-14598

CVE-2017-16853

·

Published

2017-11-16

·

Updated

2018-02-04

Description by

CVSS 3.1
8.1
High
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions OpenSAML versions prior to 2.6.1
Description The issue arises from the DynamicMetadataProvider class in OpenSAML-C, which fails to properly configure itself with the MetadataFilter plugins. This failure leads to a lack of critical security checks, including signature verification and enforcement of validity periods. These checks are crucial for secure deployments.
Recommendations For versions prior to 2.6.1, update to version 2.6.1 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DLA-1178-1
DSA-4039-1
OPENSUSE-SU-2017_3241-1
OPENSUSE-SU-2024:11122-1
SUSE-SU-2017:3234-1
SUSE-SU-2017_3234-1
Found an issue in the description? Have something to add? Feel free to write us 👾