PT-2017-14611

CVE-2017-16876

·

Published

2017-12-29

·

Updated

2026-08-24

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Mistune versions prior to 0.8.1
Description The issue concerns a Cross-Site Scripting (XSS) vulnerability in the keyify function. This vulnerability allows remote attackers to inject arbitrary web scripts or HTML by exploiting the failure to escape the key argument.
Recommendations For versions prior to 0.8.1, update to version 0.8.1 or later to resolve the issue. As a temporary workaround, consider restricting the input to the keyify function to minimize the risk of exploitation. Avoid using the key argument in sensitive operations until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-98GJ-WWXM-CJ3H
MGASA-2018-0066
OPENSUSE-SU-2024:11239-1
OPENSUSE-SU-2024:13453-1
OPENSUSE-SU-2024:14148-1
OPENSUSE-SU-2026:11585-1
PYSEC-2017-18
Found an issue in the description? Have something to add? Feel free to write us 👾