PT-2017-14855

CVE-2017-17558

·

Published

2017-12-12

·

Updated

2019-05-14

Description by

CVSS 2.0
7.2
High
MetricsAV:L/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 4.14.6
Description The issue is related to the usb destroy configuration function in the USB core subsystem, which does not properly consider the maximum number of configurations and interfaces before releasing resources. This can be exploited by local users via a crafted USB device to cause a denial of service or possibly have other unspecified impacts.
Recommendations For Linux kernel versions prior to 4.14.6, update to version 4.14.6 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2017-2802
ALT-PU-2018-1991
CESA-2018_1062
DLA-1232-1
DSA-4073-1
DSA-4082-1
RHSA-2018:0676
RHSA-2018_0676
RHSA-2018:1062
RHSA-2018_1062
RHSA-2019:1170
RHSA-2019:1190
SUSE-SU-2018:0011-1
SUSE-SU-2018:0031-1
SUSE-SU-2018:0040-1
SUSE-SU-2018:0115-1
SUSE-SU-2018:0180-1
USN-3619-1
USN-3619-2
USN-3754-1
Found an issue in the description? Have something to add? Feel free to write us 👾