PT-2017-14971

CVE-2017-17727

·

Published

2017-12-18

·

Updated

2018-01-04

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions DedeCMS versions prior to 5.7
Description The issue allows for arbitrary file upload and PHP code execution. This can be achieved by embedding PHP code in a .jpg file and using it in the templet parameter to the "member/article edit.php" endpoint.
Recommendations For versions prior to 5.7, update to version 5.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the "member/article edit.php" endpoint to minimize the risk of exploitation. Avoid using the templet parameter in the affected endpoint until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾