PT-2017-15111
CVE-2017-17935
·
Published
2017-07-31
·
Updated
2019-10-03
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Wireshark versions prior to 2.2.12
Description
The issue is related to the
File read line function in epan/wslua/wslua file.c, which does not properly strip ' ' characters. This allows remote attackers to cause a denial of service, resulting in a buffer underflow and application crash, via a crafted packet that triggers the attempted processing of an empty line.Recommendations
For Wireshark versions prior to 2.2.12, update to version 2.2.12 or later to resolve the issue. As a temporary workaround, consider restricting the processing of crafted packets to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾