PT-2017-15551

CVE-2017-2809

·

Published

2017-09-14

·

Updated

2022-04-19

Description by

CVSS 4.0
8.5
High
MetricsAV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions ansible-vault versions prior to 1.0.5
Description The issue concerns the yaml loading functionality, where a specially crafted vault can execute arbitrary python commands, resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.
Recommendations For versions prior to 1.0.5, update to version 1.0.5 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-C2W9-48QC-QPJ4
PYSEC-2017-5
Found an issue in the description? Have something to add? Feel free to write us 👾