PT-2017-1561
CVE-2016-10046
·
Published
2016-08-25
·
Updated
2018-05-12
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
ImageMagick versions prior to 6.9.5-5
Description
The issue is related to a heap-based buffer overflow in the
DrawImage function, which can be exploited by remote attackers to cause a denial of service, resulting in an application crash. This can be achieved through a crafted image file.Recommendations
For versions prior to 6.9.5-5, update to version 6.9.5-5 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
DrawImage function until a patch is applied. Avoid processing untrusted or specially crafted image files with the affected function to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾