PT-2017-15694
CVE-2017-3161
·
Published
2017-04-26
·
Updated
2022-05-13
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Apache Hadoop versions prior to 2.7.0
Description
The issue concerns a cross-site scripting (XSS) attack. It occurs through an unescaped query parameter in the HDFS web UI. This allows for potential malicious script injection and execution.
Recommendations
For versions prior to 2.7.0, update to version 2.7.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the HDFS web UI to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾