PT-2017-16589
CVE-2017-5581
·
Published
2017-01-13
·
Updated
2018-01-05
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
TigerVNC versions prior to 1.7.1
Description
The issue is related to a buffer overflow in the ModifiablePixelBuffer::fillRect function. This allows remote servers to execute arbitrary code via an RRE message with a subrectangle outside framebuffer boundaries.
Recommendations
For versions prior to 1.7.1, update to version 1.7.1 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾