PT-2017-16644

CVE-2017-5649

·

Published

2017-04-04

·

Updated

2022-05-17

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Apache Geode versions prior to 1.1.1
Description The issue allows remote authenticated users with limited permissions to access sensitive data. Specifically, users with CLUSTER:READ but not DATA:READ permission can access the data browser page in Pulse and execute an OQL query, exposing stored data in the cluster.
Recommendations For Apache Geode versions prior to 1.1.1, update to version 1.1.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the Pulse data browser page for users with only CLUSTER:READ permission until the update is applied.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-2GW6-73WC-X88F
Found an issue in the description? Have something to add? Feel free to write us 👾