PT-2017-1668
CVE-2017-2442
·
Published
2017-04-01
·
Updated
2025-09-29
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
iOS versions prior to 10.3
Safari versions prior to 10.1
Description
The issue involves the WebKit JavaScript Bindings component and is caused by insufficient input validation. It allows remote attackers to bypass the Same Origin Policy and obtain sensitive information via a specially crafted web site.
Recommendations
For iOS versions prior to 10.3, update to version 10.3 or later to resolve the issue.
For Safari versions prior to 10.1, update to version 10.1 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾