PT-2017-1686
CVE-2017-2464
·
Published
2017-04-01
·
Updated
2025-09-29
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
iOS versions prior to 10.3
Safari versions prior to 10.1
tvOS versions prior to 10.2
Description
The issue involves the WebKit component and allows remote attackers to execute arbitrary code or cause a denial of service, resulting in memory corruption and application crash, via a crafted web site. This is caused by a buffer overflow in memory.
Recommendations
For iOS versions prior to 10.3, update to version 10.3 or later.
For Safari versions prior to 10.1, update to version 10.1 or later.
For tvOS versions prior to 10.2, update to version 10.2 or later.
As a temporary workaround, consider restricting access to the WebKit component until a patch is available.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾