PT-2017-17048
CVE-2017-6410
·
Published
2017-03-02
·
Updated
2019-10-03
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
KDE kio versions prior to 5.32
kdelibs versions prior to 4.14.30
Description
The issue allows remote attackers to obtain sensitive information via a crafted PAC file. This is due to the
kpac/script.cpp in KDE kio and kdelibs calling the PAC FindProxyForURL function with a full https URL, potentially including Basic Authentication credentials, a query string, or PATH INFO.Recommendations
For KDE kio versions prior to 5.32, update to version 5.32 or later.
For kdelibs versions prior to 4.14.30, update to version 4.14.30 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾