PT-2017-1737

CVE-2016-10060

·

Published

2016-06-05

·

Updated

2021-04-28

Description by

CVSS 3.1
6.5
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions prior to 7.0.1-10
Description The issue exists due to insufficient input validation in the ConcatenateImages function. This allows a remote attacker to cause a denial of service, resulting in the application crashing, by using a specially crafted file. The vulnerability is related to the lack of return value checking for the fputc function.
Recommendations For versions prior to 7.0.1-10, update to version 7.0.1-10 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ConcatenateImages function until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-1580
DLA-756-1
SUSE-SU-2017:0529-1
SUSE-SU-2017:0586-1
Found an issue in the description? Have something to add? Feel free to write us 👾