PT-2017-17597
CVE-2017-7235
·
Published
2017-03-23
·
Updated
2019-10-03
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
cloudflare-scrape versions 1.6.6 through 1.7.1
Description
A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website.
Recommendations
For versions 1.6.6 through 1.7.1, update to version 1.8.0 to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾