PT-2017-17678

CVE-2017-7346

·

Published

2017-03-30

·

Updated

2018-07-09

Description by

CVSS 3.1
5.5
Medium
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 4.10.8
Description The issue allows local users to cause a denial of service, resulting in a system hang, by making a crafted ioctl call for a /dev/dri/renderD* device. This is due to the lack of validation of certain levels data in the vmw gb surface define ioctl function.
Recommendations For Linux kernel versions prior to 4.10.8, update to version 4.10.8 or later to resolve the issue. As a temporary workaround, consider restricting access to the /dev/dri/renderD* device to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2017-1399
ALT-PU-2018-1991
DSA-3927-1
DSA-3945-1
OPENSUSE-SU-2017_1633-1
SUSE-SU-2017:1853-1
SUSE-SU-2017:1990-1
USN-3358-1
USN-3359-1
USN-3360-1
USN-3360-2
USN-3364-1
USN-3364-2
USN-3364-3
USN-3371-1
Found an issue in the description? Have something to add? Feel free to write us 👾