PT-2017-17878
CVE-2017-7678
·
Published
2017-07-12
·
Updated
2018-11-09
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Apache Spark versions prior to 2.2.0
Description
The issue allows an attacker to trick users into visiting a malicious link that submits data, including MHTML, to the Spark master or history server. This data could contain a script that would be reflected back to the user and potentially executed by MS Windows-based clients when viewing elements of the Spark web UIs. The attack exploits the user's trust in the server.
Recommendations
For versions prior to 2.2.0, update to version 2.2.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the Spark web UIs to minimize the risk of exploitation. Avoid clicking on untrusted links that point to shared Spark clusters.
Found an issue in the description? Have something to add? Feel free to write us 👾