PT-2017-17926

CVE-2017-7755

·

Published

2017-06-13

·

Updated

2018-08-08

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Firefox versions prior to 54 Firefox ESR versions prior to 52.2 Thunderbird versions prior to 52.2
Description The issue allows malicious DLL files to be loaded by the Firefox installer on Windows, potentially leading to privileged execution if the installer is run with elevated privileges. This issue is specific to Windows operating systems and does not affect other operating systems.
Recommendations For Firefox versions prior to 54, update to version 54 or later to resolve the issue. For Firefox ESR versions prior to 52.2, update to version 52.2 or later to resolve the issue. For Thunderbird versions prior to 52.2, update to version 52.2 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2017-1770
ALT-PU-2017-1886
MGASA-2018-0018
OPENSUSE-SU-2017_1620-1
SUSE-SU-2017:1669-1
SUSE-SU-2017:2235-1
Found an issue in the description? Have something to add? Feel free to write us 👾