PT-2017-18543
CVE-2017-8808
·
Published
2017-11-15
·
Updated
2017-12-11
Description by
CVSS 3.1
6.1
MediumMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
MediaWiki versions prior to 1.27.4
MediaWiki versions 1.28.x prior to 1.28.3
MediaWiki versions 1.29.x prior to 1.29.2
Description
The issue occurs when the $wgShowExceptionDetails setting is false and the browser sends non-standard URL escaping, leading to XSS.
Recommendations
For MediaWiki versions prior to 1.27.4, update to version 1.27.4 or later.
For MediaWiki versions 1.28.x prior to 1.28.3, update to version 1.28.3 or later.
For MediaWiki versions 1.29.x prior to 1.29.2, update to version 1.29.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾