PT-2017-18555
CVE-2017-8821
·
Published
2017-12-01
·
Updated
2024-06-15
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Tor versions 0.2.5 through 0.2.5.15
Tor versions 0.2.6 through 0.2.8.16
Tor versions 0.2.9 through 0.2.9.13
Tor versions 0.3.0 through 0.3.0.12
Tor versions 0.3.1 through 0.3.1.8
Description
The issue allows an attacker to cause a denial of service, resulting in an application hang, by providing crafted PEM input that signifies a public key requiring a password. This triggers an attempt by the OpenSSL library to ask the user for the password.
Recommendations
For Tor versions 0.2.5 through 0.2.5.15, update to version 0.2.5.16 or later.
For Tor versions 0.2.6 through 0.2.8.16, update to version 0.2.8.17 or later.
For Tor versions 0.2.9 through 0.2.9.13, update to version 0.2.9.14 or later.
For Tor versions 0.3.0 through 0.3.0.12, update to version 0.3.0.13 or later.
For Tor versions 0.3.1 through 0.3.1.8, update to version 0.3.1.9 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾