PT-2017-18683

CVE-2017-9067

·

Published

2017-05-18

·

Updated

2022-05-17

Description by

CVSS 3.1
7.0
High
MetricsAV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions MODX Revolution versions prior to 2.5.7
Description The issue arises from insufficient validation of the action parameter to the "setup/index.php" endpoint, allowing an attacker to include and execute arbitrary files on the web server due to directory traversal. This can occur when PHP 5.3.3 is used.
Recommendations For MODX Revolution versions prior to 2.5.7, update to version 2.5.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the "setup/index.php" endpoint to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-CGRV-6H2H-6F7V
Found an issue in the description? Have something to add? Feel free to write us 👾