PT-2017-18926

CVE-2017-9444

·

Published

2017-06-05

·

Updated

2017-06-12

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions BigTree CMS versions prior to 4.2.19
Description The issue is related to CSRF, allowing modification of user information, removal of packages, ignoring versions, and setting FTP directories. Specifically, it affects the "core/admin/modules/users/profile/update.php" script, the "index.php/admin/developer/packages/delete/" URI, the "index.php/admin/developer/upgrade/ignore/?versions=" URI, and the "index.php/admin/developer/upgrade/set-ftp-directory/" URI.
Recommendations For BigTree CMS versions prior to 4.2.19, update to version 4.2.19 or later to resolve the issue. As a temporary workaround, consider implementing CSRF protection measures, such as token-based validation, for the affected scripts and URIs. Restrict access to the vulnerable URIs, including "index.php/admin/developer/packages/delete/", "index.php/admin/developer/upgrade/ignore/?versions=", and "index.php/admin/developer/upgrade/set-ftp-directory/", to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾