PT-2017-19195

CVE-2017-9802

·

Published

2017-08-14

·

Updated

2022-05-14

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Apache Sling Servlets Post versions prior to 2.3.22
Description The issue concerns the Javascript method Sling.evalString() which uses the javascript eval function to parse input strings. This allows for XSS attacks by passing specially crafted input strings.
Recommendations For versions prior to 2.3.22, update to version 2.3.22 or later to resolve the issue. As a temporary workaround, consider restricting the use of the Sling.evalString() method to minimize the risk of exploitation.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-8C82-9RGP-4QVR
Found an issue in the description? Have something to add? Feel free to write us 👾