PT-2017-19206

CVE-2017-9834

·

Published

2017-09-07

·

Updated

2017-09-18

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions WatuPRO plugin versions prior to 5.5.3.7
Description The issue allows remote attackers to execute arbitrary SQL commands. This is achieved by exploiting the watupro questions parameter in a watupro submit action to the "/wp-admin/admin-ajax.php" API endpoint.
Recommendations For versions prior to 5.5.3.7, update to version 5.5.3.7 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/wp-admin/admin-ajax.php" API endpoint to minimize the risk of exploitation. Avoid using the watupro questions parameter in the affected API endpoint until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾