PT-2017-2111

CVE-2016-2173

·

Published

2017-04-21

·

Updated

2022-05-13

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Spring AMQP versions prior to 1.5.5
Description The issue is related to insufficient input validation in the org.springframework.core.serializer.DefaultDeserializer component of the Spring AMQP application for RabbitMQ message exchange. This allows a remote attacker to execute arbitrary code.
Recommendations For versions prior to 1.5.5, update to version 1.5.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the DefaultDeserializer component to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-HRP3-8P5W-27GV
Found an issue in the description? Have something to add? Feel free to write us 👾