PT-2017-2403
CVE-2016-9317
·
Published
2017-01-26
·
Updated
2024-06-15
Description by
CVSS 2.0
7.1
HighMetricsAV:N/AC:M/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
GD Graphics Library versions prior to 2.2.4
Description
The issue is related to insufficient input validation in the
gdImageCreate function, which can be exploited by remote attackers to cause a denial of service, resulting in a system hang. This can be achieved by using an oversized image.Recommendations
For versions prior to 2.2.4, update to version 2.2.4 or later to resolve the issue. As a temporary workaround, consider validating and limiting the size of input images to prevent oversized images from being processed by the
gdImageCreate function. Found an issue in the description? Have something to add? Feel free to write us 👾