PT-2017-2767

CVE-2017-12933

·

Published

2017-02-16

·

Updated

2019-10-03

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.31 PHP versions 7.0.x prior to 7.0.21 PHP versions 7.1.x prior to 7.1.7
Description The issue is related to the finish nested data function in the ext/standard/var unserializer.re file of the PHP interpreter. It is caused by a buffer over-read operation when unserializing untrusted data. This can allow a remote attacker to have an unspecified impact on the integrity of PHP data.
Recommendations For PHP versions prior to 5.6.31, update to version 5.6.31 or later. For PHP versions 7.0.x prior to 7.0.21, update to version 7.0.21 or later. For PHP versions 7.1.x prior to 7.1.7, update to version 7.1.7 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2017-1822
DLA-1076-1
DSA-4080-1
DSA-4081-1
RHSA-2018:1296
SUSE-SU-2017:2468-1
SUSE-SU-2017:2518-1
SUSE-SU-2017_2518-1
SUSE-SU-2017:2522-1
USN-3566-1
USN-3566-2
Found an issue in the description? Have something to add? Feel free to write us 👾