PT-2017-2997
CVE-2017-10784
·
Published
2017-07-01
·
Updated
2026-09-18
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Ruby versions prior to 2.2.8
Ruby versions 2.3.x prior to 2.3.5
Ruby versions 2.4.x through 2.4.1
Description
The issue is related to the Basic authentication code in the WEBrick library in Ruby, which allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute arbitrary commands via a crafted user name. This is due to improper handling of log output. An attacker could exploit this issue by using a specially prepared username, potentially allowing them to execute arbitrary commands in the user's terminal emulator.
Recommendations
For Ruby versions prior to 2.2.8, update to version 2.2.8 or later.
For Ruby versions 2.3.x prior to 2.3.5, update to version 2.3.5 or later.
For Ruby versions 2.4.x through 2.4.1, update to a version later than 2.4.1.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾