PT-2017-3083
CVE-2017-15592
·
Published
2017-10-12
·
Updated
2019-10-03
Description by
CVSS 3.1
8.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Xen versions prior to 4.10
Description
The issue is related to inadequate access control in the Xen hypervisor, which can be exploited by an attacker with local access to an x86 guest operating system account in Hardware Virtual Machine (HVM) mode. This exploitation can lead to a denial of service (hypervisor crash) or potentially allow the attacker to gain elevated privileges. The problem arises from the mishandling of self-linear shadow mappings for translated guests.
Recommendations
For Xen versions prior to 4.10, update to version 4.10 or later to resolve the issue. As a temporary workaround, consider restricting access to the hypervisor to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾