PT-2017-4051

CVE-2017-5845

·

Published

2017-01-20

·

Updated

2026-10-14

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions GStreamer versions prior to 1.10.3
Description The issue is related to the gst avi demux parse ncdt function in the gst-plugins-good plugin of the GStreamer multimedia framework. It allows remote attackers to cause a denial of service due to an invalid memory read and crash. This can be achieved by using a specially crafted ncdt sub-tag that exceeds the boundaries of the surrounding tag.
Recommendations For versions prior to 1.10.3, update to version 1.10.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the gst avi demux parse ncdt function until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2017-1106
CESA-2017_2060
CLEANSTART-2026-SI50650
DSA-3820-1
MGASA-2017-0348
RHSA-2017:2060
RHSA-2017_2060
SUSE-SU-2017:1010-1
USN-3245-1
Found an issue in the description? Have something to add? Feel free to write us 👾