PT-2017-4099

CVE-2015-8857

·

Published

2017-01-23

·

Updated

2021-10-28

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions uglify-js versions prior to 2.4.24
Description The issue is related to errors in input syntax checking in the uglify-js library, which may allow a remote attacker to execute arbitrary code using a specially crafted JavaScript. The vulnerability is caused by the library not properly accounting for non-boolean values when rewriting boolean expressions, potentially allowing attackers to bypass security mechanisms. This may have an unspecified impact by leveraging improperly rewritten JavaScript. Crafted JavaScript may have altered functionality after minification.
Recommendations Upgrade UglifyJS to version >= 2.4.24.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-34R7-Q49F-H37C
GHSA-G6F4-J6C2-W3P3
Found an issue in the description? Have something to add? Feel free to write us 👾