PT-2017-4185
CVE-2016-10158
·
Published
2017-01-24
·
Updated
2018-05-04
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.30
PHP versions 7.0.x prior to 7.0.15
PHP versions 7.1.x prior to 7.1.1
Description
The issue is related to errors in number processing in the
exif convert any to int function. This can be exploited by remote attackers to cause a denial of service (application crash) via crafted EXIF data. The exploitation is possible due to an attempt to divide the minimum representable negative integer by -1.Recommendations
For PHP versions prior to 5.6.30, update to version 5.6.30 or later.
For PHP versions 7.0.x prior to 7.0.15, update to version 7.0.15 or later.
For PHP versions 7.1.x prior to 7.1.1, update to version 7.1.1 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾