PT-2017-6737

CVE-2015-4089

·

Published

2017-09-19

·

Updated

2019-09-01

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions WP Fastest Cache plugin versions prior to 0.8.3.5
Description The issue concerns multiple cross-site request forgery (CSRF) vulnerabilities in the optionsPageRequest function within the admin.php file of the WP Fastest Cache plugin. These vulnerabilities allow remote attackers to hijack the authentication of victims for requests that call specific methods, including saveOption, deleteCache, deleteCssAndJsCache, or addCacheTimeout, via manipulation of the wpFastestCachePage parameter in the WpFastestCacheOptions/ page.
Recommendations For WP Fastest Cache plugin versions prior to 0.8.3.5, update to version 0.8.3.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the admin.php file and the WpFastestCacheOptions/ page to minimize the risk of exploitation. Avoid using the wpFastestCachePage parameter in the affected page until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾