PT-2017-6839
CVE-2015-5258
·
Published
2017-08-22
·
Updated
2022-05-13
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
springframework-social versions prior to 1.1.3
Description
The issue is related to a cross-site request forgery (CSRF) vulnerability. This type of vulnerability allows an attacker to trick a user into performing unintended actions on a web application that the user is authenticated to.
Recommendations
For versions prior to 1.1.3, update to version 1.1.3 or later to resolve the issue. As a temporary workaround, consider implementing additional CSRF protection measures, such as token-based validation, to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾