PT-2017-6861
CVE-2015-5468
·
Published
2017-05-23
·
Updated
2017-06-01
Description by
CVSS 2.0
5.0
MediumMetricsAV:N/AC:L/Au:N/C:P/I:N/A:N
Name of the Vulnerable Software and Affected Versions
WP e-Commerce Shop Styling plugin versions prior to 2.6
Description
A directory traversal issue exists, allowing remote attackers to read arbitrary files. This is achieved by using a .. (dot dot) in the
filename parameter to the "includes/download.php" endpoint.Recommendations
For versions prior to 2.6, update to version 2.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the "includes/download.php" endpoint until the update is applied. Avoid using the
filename parameter with untrusted input in the affected endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾