PT-2017-7252
CVE-2015-7666
·
Published
2017-12-27
·
Updated
2019-07-26
Description by
CVSS 2.0
4.3
MediumMetricsAV:N/AC:M/Au:N/C:N/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Payment Form for PayPal Pro plugin versions prior to 1.0.2
Description
The issue concerns multiple cross-site scripting (XSS) vulnerabilities in the cp ppp admin int message list.inc.php file. These vulnerabilities are located in the (1) cp updateMessageItem and (2) cp deleteMessageItem functions. Remote attackers can inject arbitrary web script or HTML via the
cal parameter.Recommendations
For versions prior to 1.0.2, update to version 1.0.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the cp ppp admin int message list.inc.php file to minimize the risk of exploitation. Avoid using the
cal parameter in the affected functions until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾