PT-2017-7456

CVE-2015-8626

·

Published

2015-12-24

·

Updated

2017-08-22

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions MediaWiki versions prior to 1.23.12 MediaWiki versions 1.24.x prior to 1.24.5 MediaWiki versions 1.25.x prior to 1.25.4 MediaWiki versions 1.26.x prior to 1.26.1
Description The issue allows remote attackers to obtain access via a brute-force attack due to the generation of passwords smaller than the minimal required length. This is caused by the User::randomPassword function.
Recommendations For MediaWiki versions prior to 1.23.12, update to version 1.23.12 or later. For MediaWiki versions 1.24.x prior to 1.24.5, update to version 1.24.5 or later. For MediaWiki versions 1.25.x prior to 1.25.4, update to version 1.25.4 or later. For MediaWiki versions 1.26.x prior to 1.26.1, update to version 1.26.1 or later.
Exploitability
Exploit
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2017-2095
MGASA-2015-0486
Found an issue in the description? Have something to add? Feel free to write us 👾