PT-2017-7776

CVE-2016-10162

·

Published

2017-01-24

·

Updated

2018-05-04

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions PHP versions 7.0.0 through 7.0.14 PHP versions 7.1.0 through 7.1.0
Description The issue allows remote attackers to cause a denial of service, resulting in a NULL pointer dereference and application crash. This occurs when an inapplicable class name is present in a wddxPacket XML document, leading to mishandling in a wddx deserialize call. The php wddx pop element function in ext/wddx/wddx.c is specifically affected.
Recommendations For PHP versions 7.0.0 through 7.0.14, update to version 7.0.15 or later. For PHP versions 7.1.0 through 7.1.0, update to version 7.1.1 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2017-1114
OPENSUSE-SU-2017_0588-1
RHSA-2018:1296
SUSE-SU-2017:0534-1
USN-3211-1
USN-3211-2
Found an issue in the description? Have something to add? Feel free to write us 👾