PT-2017-8715

CVE-2016-5394

·

Published

2017-07-19

·

Updated

2022-05-13

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Apache Sling versions prior to 1.0.12
Description The issue arises from the XSS Protection API module, where the encoding performed by the XSSAPI.encodeForJSString() method is not restrictive enough. This allows script tags to pass through unencoded for certain input patterns, potentially leading to XSS vulnerabilities.
Recommendations For versions prior to 1.0.12, update to version 1.0.12 or later to resolve the issue. As a temporary workaround, consider restricting the use of the XSSAPI.encodeForJSString() method until a patch is applied.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-XWF4-88XR-HX2J
Found an issue in the description? Have something to add? Feel free to write us 👾