PT-2017-9416

CVE-2016-7925

·

Published

2017-01-27

·

Updated

2024-06-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions tcpdump versions prior to 4.9.0
Description The issue is related to a buffer overflow in the compressed SLIP parser and the ISO CLNS parser. Specifically, the buffer overflow occurs in the sl if print() function in print-sl.c and the clnp print() function in print-isoclns.c. This can be exploited by sending an overly long argument, potentially allowing a remote attacker to execute arbitrary code on the system or cause the application to crash.
Recommendations For versions prior to 4.9.0, update to version 4.9.0 or later to resolve the issue. As a temporary workaround, consider disabling the sl if print() and clnp print() functions until a patch is available. Restrict access to the vulnerable print-sl.c and print-isoclns.c modules to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
ALT-PU-2019-1321
CESA-2017_1871
DLA-809-1
DSA-3775-1
MGASA-2017-0061
OPENSUSE-SU-2024:11425-1
RHSA-2017:1871
RHSA-2017_1871
SUSE-SU-2017:0656-1
SUSE-SU-2017:1110-1
USN-3205-1
Found an issue in the description? Have something to add? Feel free to write us 👾