PT-2017-9441
CVE-2016-7975
·
Published
2017-01-27
·
Updated
2024-06-15
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
tcpdump versions prior to 4.9.0
Description
The issue is related to a buffer overflow in the TCP parser and the ISO CLNS parser. This buffer overflow is caused by improper bounds checking, which can be exploited by sending an overly long argument. As a result, a remote attacker could overflow a buffer and execute arbitrary code on the system or cause the application to crash.
Recommendations
For versions prior to 4.9.0, update to version 4.9.0 or later to resolve the issue.
As a temporary workaround, consider restricting access to the tcpdump application to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾