PT-2017-9781
CVE-2016-8751
·
Published
2017-06-14
·
Updated
2019-03-01
Description by
CVSS 3.1
4.8
MediumMetricsAV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Apache Ranger versions prior to 0.6.3
Description
The issue allows admin users to store arbitrary javascript code, which is executed when normal users login and access policies, due to a Stored Cross-Site Scripting vulnerability when entering custom policy conditions.
Recommendations
For versions prior to 0.6.3, update to version 0.6.3 or later to resolve the issue. As a temporary workaround, consider restricting access to custom policy conditions to prevent potential exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾