PT-2018-10157
CVE-2018-10884
·
Published
2018-08-22
·
Updated
2019-10-09
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Ansible Tower versions prior to 3.1.8 and 3.2.6
Description
The issue allows for cross-site request forgery (CSRF) in the awx/api/authentication.py module. An attacker could exploit this by tricking already authenticated users into visiting a malicious site, thereby hijacking the
authtoken cookie.Recommendations
For versions prior to 3.1.8, update to version 3.1.8 or later.
For versions prior to 3.2.6, update to version 3.2.6 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾