PT-2018-10477
CVE-2018-11319
·
Published
2018-05-20
·
Updated
2019-10-03
Description by
CVSS 2.0
8.5
HighMetricsAV:N/AC:M/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Syntastic (aka vim-syntastic) versions prior to 3.9.0
Description
The issue arises from improper handling of searches for configuration files, where the search spans from the current directory up to potentially the root. This could potentially be exploited for arbitrary code execution via a malicious gcc plugin, provided an attacker has write access to a directory that is a parent of the project's base directory. It's noted that exploitation becomes more challenging after version 3.8.0, as it may require filename prediction.
Recommendations
For versions prior to 3.9.0, update to version 3.9.0 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾