PT-2018-11160

CVE-2018-12421

·

Published

2018-06-14

·

Updated

2018-08-10

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions LTB (aka LDAP Tool Box) Self Service Password versions prior to 1.3
Description The issue allows a change to a user password without knowing the old password via a crafted POST request. This is due to the mishandling of the ldap bind return value and the lack of constraint on the PHP data type to be a string.
Recommendations For versions prior to 1.3, update to version 1.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the password change functionality until the update is applied.
Exploitability
Fix
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾