PT-2018-12626
CVE-2018-14630
·
Published
2018-09-17
·
Updated
2022-05-13
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
moodle versions prior to 3.5.2
moodle versions prior to 3.4.5
moodle versions prior to 3.3.8
moodle versions prior to 3.1.14
Description
The issue allows for intentional remote code execution when importing legacy 'drag and drop into text' (ddwtos) type quiz questions. This could lead to the injection and execution of PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.
Recommendations
For versions prior to 3.5.2, update to version 3.5.2 or later.
For versions prior to 3.4.5, update to version 3.4.5 or later.
For versions prior to 3.3.8, update to version 3.3.8 or later.
For versions prior to 3.1.14, update to version 3.1.14 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾