PT-2018-12627

CVE-2018-14631

·

Published

2018-09-17

·

Updated

2022-05-13

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions moodle versions prior to 3.5.2 moodle versions prior to 3.4.5 moodle versions prior to 3.3.8
Description The issue concerns a reflected XSS vulnerability due to insufficient filtering of the search parameter in the breadcrumb navigation provided by the Boost theme when displaying search results of a blog. This could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.
Recommendations For versions prior to 3.5.2, update to version 3.5.2 or later. For versions prior to 3.4.5, update to version 3.4.5 or later. For versions prior to 3.3.8, update to version 3.3.8 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-GQRP-QHV8-PHRV
Found an issue in the description? Have something to add? Feel free to write us 👾