PT-2018-12896
CVE-2018-15142
·
Published
2018-08-13
·
Updated
2018-10-10
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
OpenEMR versions prior to 5.0.1.4
Description
The issue allows a remote attacker authenticated in the patient portal to execute arbitrary PHP code. This is achieved by writing a file with a PHP extension via the
docid and content parameters and accessing it in the traversed directory. The attacker can exploit this by using directory traversal techniques in the portal/import template.php file.Recommendations
For versions prior to 5.0.1.4, update to version 5.0.1.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the portal/import template.php file and limiting the ability to write files with PHP extensions via the
docid and content parameters.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾