PT-2018-12901
CVE-2018-15147
·
Published
2018-08-15
·
Updated
2018-10-12
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
OpenEMR versions prior to 5.0.1.4
Description
The issue allows a remote authenticated attacker to execute arbitrary SQL commands. This is achieved via the
id parameter in the interface/forms admin/forms admin.php file, which is affected by the SQL injection vulnerability. The library/registry.inc file is also involved in this issue.Recommendations
For versions prior to 5.0.1.4, update to version 5.0.1.4 or later to resolve the issue. As a temporary workaround, consider restricting access to the 'id' parameter in the affected interface to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾