PT-2018-13557
CVE-2018-16421
·
Published
2018-09-04
·
Updated
2024-06-15
Description by
CVSS 3.1
6.6
MediumMetricsAV:P/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
OpenSC versions prior to 0.19.0-rc1
Description
The issue is related to several buffer overflows that occur when handling responses from a CAC Card in the
cac get serial nr from CUID function in libopensc/card-cac.c. This could be exploited by attackers who can supply crafted smartcards, potentially leading to a denial of service (application crash) or other unspecified impacts.Recommendations
For versions prior to 0.19.0-rc1, update to version 0.19.0-rc1 or later to resolve the issue. As a temporary workaround, consider restricting the use of crafted smartcards to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾